Страница 1 из 2 12 ПоследняяПоследняя
Показано с 1 по 10 из 13

Тема: MS 4d библиотека HVaC поведение объектов.

  1. #1

    По умолчанию MS 4d библиотека HVaC поведение объектов.

    Доброго времени суток!
    Не могу понять поведение объектов из стандартной библиотеки HVaC.
    Например, добавляю из библиотеки Вентилятор вытяжки, ставлю параметр "ИндикаторНаличие" -> "HasNoBar"
    во время исполнения индикатор мощности не исчезает, аналогично с другими параметрами..., ощущение, что все откуда то по умолчанию берется...
    В чем может быть причина? Как побороть...?

  2. #2

    По умолчанию

    В режиме разработки индикатора мощности нет, в режиме выполнения он появляется...

  3. #3

    По умолчанию

    Загрузил пример "Вентиляция" пробую отключать индикатор мощности - такая же картина, в проекте отключается, при выполнении остается на месте...

  4. #4

    По умолчанию

    ...пошел дальше в своих исследованиях, поставил кнопку, которая меняет параметр "ИндикаторНаличие" True/False, как ни странно параметр нахоится в состоянии False после запуска на выполнение, но индикатор в наличии, перевожу в True, без изменений, перевожу в False индикатор исчезаем, можно далее им так управлять, почему, все таки при старте игнорируются значения параметров установленные...

  5. #5

    По умолчанию

    Если я правильно понял проблему - вам нужно сделать точечную конвертацию параметра.

  6. #6

    По умолчанию

    Думаю что нет, при старте параметры установлены в нужные значения, но они не соответствуют состоянию объекта на экране, вроде все начальные значения установил, не понимаю...

  7. #7

    По умолчанию

    Киньте сюда проект

  8. #8

    По умолчанию

    Цитата Сообщение от DimBan Посмотреть сообщение
    ...пошел дальше в своих исследованиях, поставил кнопку, которая меняет параметр "ИндикаторНаличие" True/False, как ни странно параметр нахоится в состоянии False после запуска на выполнение, но индикатор в наличии, перевожу в True, без изменений, перевожу в False индикатор исчезаем, можно далее им так управлять, почему, все таки при старте игнорируются значения параметров установленные...
    Такая ошибка была в одной из прошлых версий. Вы в какой сейчас работаете?

  9. #9

    По умолчанию

    Версия: 1.2.3.6154(MPLCD_1_2_20181004.1), очень похоже на ошибку...

  10. #10

    По умолчанию

    Спасибо за совет!!! Обновил до Версия: 1.2.4.8341(MPLCD_1_2_20190218.1), проверяю, вроде все заработало, кроме жалюзи вытяжки/притока все время в закрытом состоянии, не могу открыть, если беру из палитры компонентов то открываются, если беру из библиотеки, то нет..., похоже то же ошибка или какие то условия нужно выполнить?

Страница 1 из 2 12 ПоследняяПоследняя

Похожие темы

  1. Ответов: 11
    Последнее сообщение: Вчера, 16:37
  2. Защита объектов проекта
    от serj_ant в разделе Master SCADA
    Ответов: 2
    Последнее сообщение: 05.12.2018, 15:20
  3. дерево объектов
    от Ziza в разделе Master SCADA
    Ответов: 3
    Последнее сообщение: 20.02.2018, 12:44
  4. ВФБ HVAC
    от ASo в разделе Master SCADA
    Ответов: 13
    Последнее сообщение: 02.02.2017, 13:51
  5. Библиотеки объектов
    от Aleksey Belokon в разделе Master SCADA
    Ответов: 4
    Последнее сообщение: 17.11.2011, 16:17

Ваши права

  • Вы не можете создавать новые темы
  • Вы не можете отвечать в темах
  • Вы не можете прикреплять вложения
  • Вы не можете редактировать свои сообщения
  •